Garmin Navigation nüvi 0x8002000a

Why should a device just work without any troubles? It looks like Apple’s the only company that tests it’s own products before releasing them to the market…

I just buyed a new Navigation unit from Garmin, called nüvi 3590, plugged it into a USB port as called in the manual (five page booklet) and visited the Garmin Homepage. There I logged in with my already existing MyGarmin Account and clicked on MyStart to search for an attached device. The only thing I get is a popup box telling me “Error 0x8002000a”. I’m just able to click OK.

What’s that?!

After some research on Google by typing in “Garmin 0x8002000a” I found a lot of others having the same issue. Don’t they attach their own devices on their computer and try to connect, before putting them onto market?

Okay, yes, this issue is only known for 64-bit Windows 7 computers. But who has Windows XP, or even a 32-bit Operating System today?

Solution to solve that issue was published by a forum poster called “thesidewinder” on the following page: https://forums.garmin.com/showthread.php?t=25318

On this page (if it’s already down) he told to do the following:

OK, just got off the phone with Garmin, and here’s what fixed the issue for me.

This is on my 2595LMT, have to assume it’s correct for other models.

Unplug unit from computer.
Power up unit and get to main screen.
Press the Volume icon.
On the volume control screen, press and hold the upper-right corner of screen for ten seconds (there’s no icon there, just press and hold the upper right corner).
A “Diagnostics” page will appear.
Scroll down and choose “MTP Settings”
It will likely say “MTP Auto Detect”. You want to change that “Mass Storage”, then press save.

Problem solved for me.

This very helpful hint is not posted on any Garmin Website. Do they really want everyone to call support, to get the answer to the Question “0x8002000a” ?

Unbelievable…